Skip to main content

animating biped without footsteps?

Posted by urgrund on Thu, 29/04/04 - 9:22 PM
Forum

I'm trying to animate (set keyframes) on a biped, but everytime I move a bone it says "Keys may nbot be set when inactive footsteps exist"

I don't want CS footsteps... when I click 'Create keys for inactive footsteps" it moves my character and rearranges the bones.

How can I get around this? I just want to be able to make animations like scratching a head (for example), stuff that doesn't use footsteps


Submitted by unknownuser2 on Thu, 29/04/04 - 9:49 PM Permalink

Thats an interesting one urgrund - which version of char studio are you using ?

Submitted by urgrund on Thu, 29/04/04 - 10:20 PM Permalink

CStudio 3

...i think i may have caused the problem orginally when mucking around with the footsteps tab. Because now there's at least one footstep that I cannot get rid of (says something like "Inactive footstpes but not all inactive footsteps may be deleted)

Usually, if I never go near that footstep tab, I can set keyframes however I like with the biped.

Submitted by Wizenedoldman on Fri, 30/04/04 - 1:32 AM Permalink

Odd indeed, can't say I've ever had a problem like that. Maybe there's some hidden keyframe somewhere that you need to delete? Maybe it's in some mode that it shouldn't be in?

Submitted by urgrund on Fri, 30/04/04 - 6:46 AM Permalink

ok, i got around it... i thought that I could 'hack' the problem by goig along with it and just do my work whilst the biped is on 2 'jump' footsteps that actually last 100% of the timeframe (so he's static).

Then I accidently deleted one of them... and all footsteps went and I was back to being able to do whatever the hell i wanted with the biped :P

Submitted by Doord on Fri, 30/04/04 - 7:53 PM Permalink

just so you know you can turn off foot step mode under the animation tab in biped roll out and un selecting the icon which looks like two foot prints.

I don't use foot step mode (the most usless thing for good animation I have even seen) so the maybe a step or two I don't know.

Submitted by Malus on Tue, 04/05/04 - 7:06 PM Permalink

quote:Originally posted by Doord
I don't use foot step mode (the most usless thing for good animation I have even seen) .....

A bit like most of Character Studios tools if you ask me. [:P]

Submitted by Anonymous (not verified) on Thu, 16/04/09 - 12:26 AM Permalink

Can you please help i gat the same problem and im going made what do i do!! HELP!!

Submitted by nanoh on Fri, 30/05/14 - 3:30 AM Permalink

Finally i got it, hope this will help: Go to footsep mode, try to delete all the foot prints on the scene except the "zero" one you can't delete. then select that last foot print, and click "create keys for inactive footprints" (I am pretty sure it was this one). Your character should change position and pose like walking. Then, select this last footstep, and delete it, it should work. Now, yours footsteps are gone, go back to figure mode to get back your original position, and that's it !

In reply to by Anonymous (not verified)

Submitted by The Northern S… on Fri, 13/06/14 - 10:07 AM Permalink

When using Biped footsteps, it's often an either/or situation. What you have is inactive footsteps in your scene. You need to select them and click the delete footsteps button (down near the activate footsteps button, about 2nd to the right). If you can't select them, activate them first, then select and delete.
A work-around is to come out of footstep mode by turning off the footsteps button (the one with the green and blue feet on it) going to the Layers rollout and adding a new animation layer. Turn on auto key and animate away. Layers allow additional animation to be placed on top of the footstep animation and will allow you to animate even if you have footsteps in the scene.